about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorgennyble <gen@nyble.dev>2025-03-11 14:42:29 -0500
committergennyble <gen@nyble.dev>2025-03-11 14:42:29 -0500
commit912ce0966c42f126d7a37c88e442e16a30308415 (patch)
treecd17b5f93c57f7ef6b17c99f776503d5ddf3803b /Cargo.toml
downloadcorgi-912ce0966c42f126d7a37c88e442e16a30308415.tar.gz
corgi-912ce0966c42f126d7a37c88e442e16a30308415.zip
works :)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..206071d
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,17 @@
+[package]
+name = "corgi"
+version = "0.1.0"
+edition = "2024"
+
+[dependencies]
+http-body-util = "0.1.3"
+hyper-util = { version = "0.1.10", features = ["tokio"] }
+
+[dependencies.tokio]
+version = "1.44.0"
+features = ["rt", "rt-multi-thread", "io-std", "net", "process"]
+
+[dependencies.hyper]
+version = "1.6.0"
+default-features = false
+features = ["server", "http1"]