about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml35
1 files changed, 3 insertions, 32 deletions
diff --git a/Cargo.toml b/Cargo.toml
index fa58787..2baef5b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,32 +1,3 @@
-[package]
-name = "corgi"
-version = "0.1.0"
-edition = "2024"
-
-[profile.release]
-#strip = true
-#opt-level = "z"
-#lto = true
-#codegen-units = 1
-
-# 1538792 none of the above flags
-#  829896 the above flags reduced binary size by around 700K :)
-
-[dependencies]
-http-body-util = "0.1.3"
-hyper-util = { version = "0.1.10", features = ["tokio"] }
-regex-lite = "0.1.6"
-
-[dependencies.confindent]
-version = "2.2.1"
-git = "https://github.com/gennyble/confindent"
-branch = "v2"
-
-[dependencies.tokio]
-version = "1.44.0"
-features = ["rt", "rt-multi-thread", "io-std", "io-util", "net", "process"]
-
-[dependencies.hyper]
-version = "1.6.0"
-default-features = false
-features = ["server", "http1"]
+[workspace]
+members = ["corgi", "parrot"]
+resolver = "3"