about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorgennyble <gen@nyble.dev>2025-03-16 05:50:30 -0500
committergennyble <gen@nyble.dev>2025-03-16 05:50:30 -0500
commit3a80b5ec7ac28b48a0e9e9ec3c7a89e8979d51a7 (patch)
tree428d119458bcb37f1bc7c9d4105b29f864aae052 /Cargo.toml
parent0530a4f68004b2ab85ad6b4f6c2cee24a05fdeaf (diff)
downloadcorgi-3a80b5ec7ac28b48a0e9e9ec3c7a89e8979d51a7.tar.gz
corgi-3a80b5ec7ac28b48a0e9e9ec3c7a89e8979d51a7.zip
corgi v1.0.0
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml11
1 files changed, 11 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 2baef5b..0924370 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,3 +1,14 @@
 [workspace]
 members = ["corgi", "parrot"]
 resolver = "3"
+
+# use this profile like this:
+# 	$ cargo build --profile size
+# and select a binary like this:
+#	$ cargo build --bin corgi
+[profile.size]
+inherits = "release"
+strip = true
+opt-level = "z"
+lto = true
+codegen-units = 1