about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml11
1 files changed, 11 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 2baef5b..0924370 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,3 +1,14 @@
 [workspace]
 members = ["corgi", "parrot"]
 resolver = "3"
+
+# use this profile like this:
+# 	$ cargo build --profile size
+# and select a binary like this:
+#	$ cargo build --bin corgi
+[profile.size]
+inherits = "release"
+strip = true
+opt-level = "z"
+lto = true
+codegen-units = 1